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Welcome

1 Welcome

Thank you for your interest in CutLogic 1D, length cutting optimization software. CutLogic

1D is a solution for finding optimal cutting layouts with minimal waste, saving your

material, time and money.

Since 2002 TMachines has provided top-class software solutions in the area of cutting

optimization for their customers. CutLogic 1D brings you the best of our know-how as

well as many improvements inspired by our customers. CutLogic 1D is available in three

editions: community, professional, and enterprise edition .

Today, our solutions help companies in more than 70 countries worldwide, on daily basis,

to minimize costs and realize significant savings.

We believe you will be satisfied with our program and we wish you a lot of savings with

CutLogic 1D.

13
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2 Contact and support

Feel free to contact us via email in any matter related to our products and services

(questions regarding pricing, ordering, licensing, or questions about program functionality

and features, or suggestions about program improvements). Your inquiries will be

processed and answered as soon as possible.

Email

support@tmachines.com

Website

www.tmachines.com



7

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

What is CutLogic 1D?

3 What is CutLogic 1D?

• CutLogic 1D is a top-class length cutting optimization software, providing you the best

way to save your material, work and time when you need to cut any linear material such

as pipes, rods, tubes, wires, profiles, bars, cables, etc.

• CutLogic 1D automatically finds optimal cutting layouts, using the most advanced

optimization techniques. Its optimization engine takes advantage of Genetic Algorithms

and Fuzzy Logic bringing better results than any other software.

• CutLogic 1D is a flexible and complete solution providing extensive features such as full

material and remnant management, enhanced reporting functionality or multi format

import and export of data for seamless integration with your existing working system

and much more.

• CutLogic 1D with OptiRefine module is the only solution on the market providing an

intelligent optimization refinement and re-optimization based on priorities different

than just costs. See chapter Refining Optimization  further in this manual for details.

Technology our optimizers are based on

Genetic Algorithms

Genetic algorithm is an algorithm that mimics evolution and competition between

individuals in natural selection. Tasks are encoded to genes of individuals and evolution

produces better individuals with better solving. Neither programmer nor genetic

algorithm has to know how to solve a given problem; solution is just bred. Genetic

algorithms are part of wider evolutionary computation and artificial intelligence.

Fuzzy Logic

Fuzzy Logic is a truth-functional system that mimics natural thinking in a sense of dealing

with the degree of truth rather than just with True and False. In Boolean logic an event can

be only False (0) or True (1); in fuzzy logic an event can be sort of true - a number

between 0 and 1.

59
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4 What's new in current version?

What's new in version 6.0?

• New free time unlimited Community Edition

• New streamlined cutting layouts report with switchable sections and improved exports

• Added export to JPG and PNG for better exporting of individual labels

• Custom exports can run other applications

• Import connection file can include SQL statement

• New auto-optimizing CutLogic 1D Server

• Fixed info printing in layout part pictures

• Several smaller improvements and fixes

Version 5.7

• Faster optimization and simpler cutting layouts for plans with duplicate stock/part sizes

• New Custom Exports module - manual or automatic exports of entire cutting plan to

xml file or (virtual) serial port

• New Custom Exports module - manual or automatic exports of any data using custom

SQL query to csv file or (virtual) serial port

• New report exports to MS Word (docx) and MS Excel (xlsx)

• New improved version of report editor and viewer

• Added Note 4 to Plans and Materials, and Note 3 to stocks and parts

• Several smaller improvements and fixes

Version 5.6

• Function to send cutting layout to serial port

• Multiple selected cutting plans can be exported to single CSV file

• Several improvements in data import

• Several smaller improvements and fixes

Version 5.3

• Improved import from Excel files

• Improved material inventory control via new fields Minimal Level and Actual Level

• Added Polish language
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• Small improvements and fixes

Version 5.2

• Added cutting setting "Maximum number of stock lengths" - allowing to limit stock

lengths used in plan; optimizer will pick best stock length(s) for given parts

• Small improvements and fixes

Version 5.1

• New improved help file

• Added Spanish language

• Improved imports

• Small improvements and fixes

Version 5.0

• Interactive graphical representation of cutting layouts

• Added German and Slovak language

• New option Part Increase - program adds this value to both sides of each parts

• Function split part(s) - useful when parts are longer than stocks

• Optional automated loading of inventory stocks to new cutting plans

• User can copy current material cutting settings to multiple selected materials

• Program can hide cutting plans older than X days (settable in program options)

• Added completion flags in part list in cutting layout reports - indicates line in which

order, length or other value is finished

• User can print part and remnant label right from cutting layout image by double click

• Improved and streamlined import and multi-material import

• Cost type can be assigned for each stock separately

• Positions, lengths and visibilities of columns in all data grids can be customized

• User can select multiple records and perform batch operations (optimizing, deleting,

printing, marking, loading, etc.)

• Function to copy record (in any data grid)

• Renumber function (renumbers number column in data grid)

• Improved graphical cutting layouts and overall GUI

• New improved version of report editor and viewer
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• Improved and streamlined all reports

• Multiple fixes

Version 4.7

• Report "Plan Cost Detail"

• Full support for Unicode - CutLogic 1D data now can include any language specific

characters

Version 4.6

• Capability to create charts in reports

• Configurable sorting of layouts and layout parts

• Several smaller improvements and fixes

Version 4.5

• Export to RazorGage system

• Several smaller improvements and fixes

Version 4.4

• Closed cutting plans can be deleted now

• Material lookup table sorted by description

• Several smaller improvements and fixes

Version 4.3

• Cutting setting "Minimize layout count" – reduces number of layouts in cutting plan

• Cutting setting "Minimum layout repeat"

• Import and export of entire cutting plan from/to CutLogic file

• Several smaller improvements and fixes

Version 4.2

• Support of feet & inches in imports

• Several smaller improvements and fixes

Version 4.1

• Import of multi-material data with automated creation of cutting plans
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• Improved import from CSV and TXT, sorting capabilities for imported data

• Batch reports

• Improved performance on WAN

• Creating multi-material cutting plans from Assemblies

• Several smaller improvements and fixes

Version 4.0

Technology

• MS Vista OS supported

• Firebird RDBMS used - more secure and reliable solution based on true SQL database

for data protection like security, backup, crash recovery, etc.

GUI

• Graphical redesign and optimization of program for more user friendly look and feel

• Enhanced data grids for better navigation and data manipulation - new sorting and

multi sorting features

• Enhanced filtering capabilities - possibility to define new improved filters for cutting

Plans, Materials, Assemblies, Storages, Stocks, Parts, etc.

New features

• Module Assemblies - can store products or orders or both

• Remnants (over) production control

• Capability to copy cutting plans

Optimization

• 30% faster optimization

• 20% decrease of cutting layouts

• Improved OptiRefine module

• Remnants (over) production control enables adjusting production of remnants and

improves total yield

Reports

• Filtering by date

• Exports embedded into Reports

• New embedded report generator and editor for customization of reports

• Improved and extended labeling systems and report sets
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• Possibility to define custom defined data views and statistics

Imports

• Imports from MS Excel files, MS Access files, CSV format

• Imports from data sources (Oracle, MS SQL Server, MySQL, Firebird, etc.) via connection

string

• Added "default" values and "multiply by" values when defining import

• Added filter enables to filter import data

Exports

• Export to CSV, MS Excel files, PDF, XML, Open Document Text, Open Document

Spreadsheet

• Send by email feature

• Improved export to TXT, RTF, and HTML

Connectivity

• Distributed connectivity enabling various scenarios in different environments (local,

LAN, WAN)

• Improved support for LAN - user management, logon security, etc.

• WAN optimization - application optimized for running in WAN environment
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5 Editions comparison

After installation, CutLogic 1D runs in Enterprise Edition mode for 30 days before

switching to the free, time unlimited Community Edition. When you register CutLogic 1D,

the Community Edition will change (depending on the license purchased) to the

Professional or Enterprise Edition.

Community

Edition

Professional

Edition

Enterprise

Edition

Cutting plan limitations [per one plan]

Max number of all parts 250 3000 Unlimited

Max number of different part sizes 10 50 Unlimited

Features

State of the art cutting optimization • • •
19 predefined reports • • •
Max number of custom reports 2 10 Unlimited

Sharing database by multiple users over LAN /

WAN

LAN LAN/WAN

OptiRefine module (parametrized re-

optimization)
• •

Function Split part(s) •

Cutting settings

Saw kerf (cut width) • • •
Left and right trims • • •
Grip size • • •
Minimum length of remnants (reusable offcuts) • • •
Minimize cutting layout count • •
Restricted length range of rests From - To • •
Max number of parts in layout • •
Max number of different part lengths in layout • •
Minimum length difference among parts in

layout
• •

Max number of stock lengths used in plan •
Minimum repeat of layout •
Part size increase •
Remnants creation control / ratio •

Inventory

Automated tracking of stocks and remnants • • •
Materials, Storages • • •
Assemblies - copy to plan • •
Assemblies - copy to multiple plans •

Import / Export

Import from clipboard, CSV, TXT • • •
Import from MS Excel • •
Import from MS Access •
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Import from any database via connection file

(ODBC / OLEDB)
•

Export to PDF, TXT, CSV, RazorGage • • •
Export to Excel, ODT • •
Export to HTML, Word, RTF, ODS •
Export to XML file • • •
Export using custom SQL data to CSV file • • •
Export to (virtual) serial port • •
Auto export after plan optimization / close /

open
•
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System requirements

6 System requirements

CutLogic 1D has been designed to work with Microsoft® Windows® 11, 10, 8, 7.

Minimum

• Intel® Pentium® processor or compatible

• 1 GB RAM

• Display 800 x 600

• 50 MB of free disk space 

• Microsoft® Windows® 11, 10, 8, 7

Recommended

• Intel Core or AMD Ryzen processor

• 4 GB RAM

• Display 1024 x 768

• 200 MB of free disk space 

• Microsoft® Windows® 11, 10
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Download and installation

7 Download and installation

Download

You are welcome to download the free version of our software at www.tmachines.com.

Direct download link: CutLogic 1D setup file

Installation

After the download is finished, go to the download folder and locate the file (i.e.

setupcl1d.exe). Double-click the file to start the installation.
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Ordering and registration

8 Ordering and registration

Ordering

Order the registered version of CutLogic 1D on-line at our website www.tmachines.com.

Here you find our latest pricing information, instructions on how to order, and link for

ordering online using a secure server.

When purchasing new license of CutLogic 1D software or upgrade from older version, you

will receive support and new versions free of charge for the first year.

Registration

When you start CutLogic 1D, select the menu item "Tools > Order and registration" and

follow the instructions.

Note: After we receive your "Machine ID", we will send you the license file by e-mail

along with instructions on how to use it to register CutLogic 1D (the e-mail will be

sent to the address you entered during the purchase).
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Program overview

9 Program overview

This chapter describes basic information about CutLogic 1D program good to know

before you start to use the program.

The basic concepts and terms

This chapter explains basic concepts and commonly used terms used in the program.

Commonly used terms

Program or CutLogic 1D means CutLogic 1D software application.

Optimization is process of finding the cutting plan with the optimized cutting layouts.

Plan represents definition of cutting plan. 

Stock represents material available for cutting; it is input into cutting plan.

Part represents piece of material required to be cut; it is input into cutting plan.

Remnant represents reusable rest of Stock (also called reusable off-cut).

Scrap represents useless rest of Stock.

Report represents special layout displaying the data in printable format.

Filter represents set of conditions filtering data.

Material represents definition of unique material. One plan may contain only one

Material.

Assembly represents unique definition of logically grouped Parts.

Storage represents definition of unique logical or physical storage or warehouse for

Materials.

Basic concepts

CutLogic 1D contains following sections:

Plans

Materials

Assemblies

Storages

You can switch among these sections by clicking one of the icons representing given

section in the tool panel or from the main menu (Machines, Edgebands).

Every section consists of one master tab and may contain more detail tabs. Master tab is

first tab displayed in tabs from the left and contains small icon.

46

87

92

95
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Program overview

CutLogic 1D is unique in term of handling and displaying master-detail relations of data.

If detail tab is applicable, following navigator is displayed in tool panel.

This navigator enables you to browse the records in related master tab while detailed

information for active detail tab is displayed on the screen. This is very helpful feature

enabling you better orientation among your data.
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Program overview

9.1 Main window

This chapter describes basic information about Graphical User Interface of CutLogic 1D.

The Main window contains following segments.

Main menu

This drop-down menu is basic control element for navigation and executions of logically

grouped commands.

Main toolbar

The Main toolbar is a collection of buttons and other control elements providing quick

access to commonly used commands.

Plans Ctrl+1 Activates the Plans enabling you to manage your

plans, their stocks, parts, settings and results.
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Materials Ctrl+2 Activates the Materials enabling you to manage

your materials, their stocks and parts.

Assemblies Ctrl+3 Activates the Assemblies enabling you to

manage your assemblies and their parts.

Storages Ctrl+4 Activates the Storages enabling you to manage

your storages and their stocks.

Reports Ctrl+P Displays the Reports form with list of available

reports in new window.

Filter Ctrl+F Displays the Filter definition form in new

window.

Import Ctrl+I Displays the Import form in new window.

Start optimization F3 Starts calculation of optimal cutting plan for

given actual plan.

Stop optimization ESC Stops calculation.

Following data navigator serves for navigation in given section. This navigator is displayed

only if other than master tab is chosen (active). This navigator enables you to browse the

master records in given section while detailed information from active detail tab is

displayed.

Function of the buttons of navigator is following.

Moves to the first record of given master data.

Moves to the previous record of given master data.

Moves to the next record of given master data.

Moves to the last record of given master data.

Tabs

Tabs are graphical control elements representing master and/or detail data. Tabs shows

one master and one or more detail tabs. Master tab is the first tab from the left in tabs

and contains small graphical icon.

Toolbar

Toolbar displays basic information about active master data and contains data navigator

and optionally displays other control elements (buttons).
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Data navigator

Data navigator serves for navigation and editing of data displayed in data grid.

Function of the buttons of navigator is following.

Moves to the first record.

Moves to the previous record.

Moves to the next record.

Moves to the last record.

Inserts a new record.

Deletes the current record.

Posts changes from the current record to the database.

Cancels changes made in the current record.

Data grid

Data grid is the main part of the form, where you can manage your data like Plans,

Materials, Storages and Assemblies. Data are usually organized in rows (records) and

columns (fields).

Light blue color represents active row.

Dark blue color represents active field within selected row.

Non editable fields are displayed with grey background.

Status bar

Status bar displays information related to element you point on by mouse (e.g. input line

in cutting settings).
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9.2 Menus

File

Plans Ctrl+1 Activates the Plans enabling you to manage

your plans, their stocks, parts, settings and

results.

Inventory This contains following three sub-menu

options...

Materials Ctrl+2 Activates the Materials enabling you to

manage your materials, their stocks and parts.

Assemblies Ctrl+3 Activates the Assemblies enabling you to

manage your assemblies and their parts.

Storages Ctrl+4 Activates the Storages enabling you to

manage your storages and their stocks.

Start optimization F3 Starts calculation of optimal cutting plan for

currently selected plan(s).

Stop optimization Esc Stops calculation.

Reports Ctrl+P Displays the Reports form in new window.

Enables working with available reports like

printing, previewing, editing and others.

Filter Ctrl+F Displays the Filter definition form in new

window. Enables defining filter conditions

and others.

Import This contains following four sub-menu

options...

Import data from Excel,

Access, CSV or connection

file

Ctrl+I Displays the Import form in new window.

Enables to import data.

Import data from

clipboard

Ctrl+J Enables to import data from clipboard.

Import plan from CutLogic

file (To new plan)

Alt+2 Enables to import entire cutting plan from

single data file. The data are imported to new

created plan.

Import plan from CutLogic

file (To current plan)

Enables to import entire cutting plan from

single data file. The data are imported to

currently selected plan.
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Export This contains following three sub-menu

options...

Export report to

PDF/Excel/Word file

Ctrl+P Displays the Reports form in new window.

Enables exporting data to PDF, MS Excel, MS

Word, CSV, RTF, ODS, ODT or HTML file.

Export cutting layouts to

CSV file

Ctrl+G Enables exporting cutting layouts to CSV file /

RazorGage system.

Send cutting layouts to

serial port

Enables sending cutting layouts to serial port.

Export plan to CutLogic file Alt+1 Enables you to export current plan to single

data file.

Custom exports Ctrl+E Opens Custom exports form where you can

define and use your own exports.

Exit Quits the application.

Tools

Calculator F8 Displays the windows calculator.

Database Ctrl+D Opens the Database administration form in

new window. Enables setup of backup and

restore procedures, server connection,

managing the users and shows database

statistics.

Language Enables you to change application language.

Order and registration Displays the information how to order and

register the full version. Shows Machine ID of

the computer.

Older versions

Import data from version

3.3 and lower

Displays the Import form in new window.

Enables to import data from older versions.

Options Ctrl+O Displays the Options form with program

options in new window.
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Edit

Copy record Enables you to do copy of currently selected

record.

Renumber column "#" Automatically renumber column "#" in

currently selected data grid.

View

Rearrange columns Enables you to rearrange columns (visibility

and order of data fields) in currently selected

data grid.

Help

CutLogic 1D help F1 Displays the contents of this help file.

CutLogic 1D online help Opens CutLogic 1D online help in your web

browser.

Visit CutLogic 1D web site Opens CutLogic 1D web site in your web

browser.

Contact support Sends an email to technical support.

About Displays the information about the product

name and current version. It also contains the

support link and our website address.
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9.3 Data sorting

This feature helps you to manage your data displayed in data grid. Click the label of given

column by left mouse button to sort displayed records. Records will be sorted according

to data values in selected column.

First click sorts data in ascending order.

Second click sorts data in descending order.

Third click cancels sorting in selected column.

Program also enables defining of sorting over multiple columns. Hold Ctrl button and

click by left mouse button on the labels of given columns to activate sorting in more

columns.

Following example shows sorting applied in Length and Qty columns.
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9.4 Data editing

You can use data navigator or mouse for navigation within the data grid. Single left click

on active editable field or pressing Enter key switch selected field in edit mode. Edit

mode enables you either to enter the data directly from the keyboard or to pass data

from the clipboard. Some fields are restricted only by the length – the maximum number

of characters.

Some editable fields are restricted by the list of predefined values. Enter the value for

such field by choosing one from related pick list.

If you leave edited row new values are automatically posted into database. You can also

post changes into database by clicking the post edit button  in the data navigator. To

cancel edit, click the button  . 
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9.5 Data filtering

Filters represent powerful tool for data presentation. You can restrict displayed data by

defining filtering conditions in Filter definition form. You can define one unique filter for

each of following sections.

Plans

Plan stocks

Plan parts

Materials

Material stocks

Material parts

Assemblies

Assembly parts 

Storages

Storage stocks

Filter definition

By clicking the button  in the main toolbar or by pressing keyboard shortcut Ctrl+F

the Filter definition form opens in new window.

Filter definition form may contain more filtering conditions. Define logical relation

among these conditions by clicking one of following radio buttons.

All of the conditions Only data which fulfill all of the defined conditions will be

displayed.

Any of the conditions Only data which fulfill at least one of the defined conditions

will be displayed.
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Adding and deleting the conditions

You can add and delete conditions of filter by clicking the chosen button.

Functions of the buttons for manipulation with the filter are described as follows.

More New condition will be added at the end of already defined

conditions. It is possible to define 9 conditions at most.

Fewer The last condition in the filter will be deleted.

Clear all All defined conditions will be deleted.

Defining and editing the conditions

You need to choose a column, operation and define the value for each of conditions.

Select column from pre-defined list of available columns. You can define conditions even

for columns not displayed in given data grid.

Tip: Select Any field value from the list if you need to define condition for all

available columns.

Select operation from pre-defined list of operations and enter the value for setting the

filter.
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Note: Use numeric value for numeric columns like Plan ID or Qty. For other columns

any string can be used.

Activation and deactivation of filter

When all conditions of the filter are set, you can activate it. For activation click the check

box Active in the Filter definition form.

The filter will display only the records which fulfill defined conditions. Activation of filter is

signalized by the red labeled information in toolbar.

Tip: It is possible to apply both, filter and data multiselection , when working with

data.

31
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9.6 Data multiselection

Data multiselection is very useful tool when working with data. You can restrict operations

on data by selecting only necessary records. You can select multiple rows or multiple

columns. Selected data can be bulk optimized, closed/opened (plans), copied (to plans or

to clipboard), deleted, printed, exported, etc.

Selecting multiple rows using mouse

• When you click on any data row and the Ctrl key is pressed, the additional single row is

selected.

• When you click  on any data row and the Shift key is pressed, all the next rows are

selected.

Selecting multiple columns using mouse

• When you click on column title the Shift key is pressed, the column is selected.

• Now, when you click on other column and the Ctrl key is pressed, this column is added

to selection.

Selecting multiple rows or columns using keyboard

• When the Shift key is pressed and the user presses Up/Down arrow key (also

PgUp/PgDn), the Rows selection is performed. When the Shift key is still held and the

user presses Left/Right arrow key (also Home/End), the Rows selection is changed to

cells selection.

• When the Shift key is pressed and the user presses Left/Right arrow key (also

Home/End), the columns selection is performed. When the Shift key is still held and the

user presses Up/Down arrow key (also PgUp/PgDn), the selection is changed to cells

selection.

Tip: It is possible to apply both, filter  and data multiselection when working with

data.

Following represents rows multiselection.

28
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Following represents columns multiselection.



33

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Program overview

9.7 Rearranging columns

It is possible to rearrange all columns in data grids. All available columns can be hidden

or shown according to your individual needs. In addition, it is also possible to change their

order. By hiding of unnecessary columns or reordering them, you can achieve better and

clearer view of your data.

To rearrange columns, click the button  in data grid or select the menu item "View >

Rearrange columns". Here you can check/uncheck visibility of data fields. 

Toolbar

Moves column down. In data grid, column is moved to the right. 

Moves column up. In data grid, column is moved to the left.

Loads default columns setting.

Tip: Alternatively, to reorder columns directly in data grid, you can click and hold

column header and drag it to left/right.
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9.8 Keyboard shortcuts

Shortcuts for quick access to the program features

Tab Moves to the next tab

Shift+Tab Moves to the previous tab

Alt+Arrow

Down

Drops down list

Ctrl+1 Opens Plans

Ctrl+2 Opens Materials

Ctrl+3 Opens Assemblies

Ctrl+4 Opens Storages

F3 Starts calculation of optimal cutting plan

Esc Stops calculation

Ctrl+F Opens Filter definition form

Ctrl+P Opens Reports form

Ctrl+O Opens Options form

Ctrl+D Opens Database administration form

Ctrl+I Opens Import form

Ctrl+J Imports data from clipboard

Ctrl+E Opens Custom exports form

Alt+1 Exports current plan to CutLogic file

Alt+2 Imports cutting plan from CutLogic file (to new plan)

Ctrl+G Exports cutting layouts to CSV file / RazorGage format file

F8 Opens Windows calculator

F1 Opens Help

Ctrl+Alt+

Arrow

Down

Moves to the next plan

Ctrl+Alt+

Arrow Up

Moves to the previous plan

Ctrl+Shift

+End

Assigns random colors to the parts of the current plan
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In data grids only

F2 Edits current field / Opens pick list for current field / Switches stock qty 0 <-

> unlimited

Esc Cancels edit mode

Ctrl+Del Deletes current record

Ins Inserts new record

Ctrl+V Clones current record

Arrow Up Moves to the previous record

Arrow

Down

Moves to the next record

Page Up Moves to the previous page of records

Page

Down

Moves to the next page of records

Ctrl+Hom

e

Moves to the first record

Ctrl+End Moves to the last record

Enter/Ret

urn

Switches between field's edit and view modes

Shift+Arro

w Up

Adds the previous record to selection

Shift+Arro

w Down

Adds the next record to selection

Ctrl+A Selects all records

Tab Moves to next field

Shift Tab Moves to previous field

Home Jumps to first (most left) field (only if current field is in view mode)

End Jumps to last (most right) field (only if current field is in view mode)

Space Moves cursor through feet -> inches -> fraction > feet when editing

feet/inches value
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10 Program Options

To work with program Options, select the menu item "Tools > Options" or press Ctrl+O.

In Options you can set the main parameters of the program. Correct representation and

displaying of the data in the project depends on setting of some parameters like Type,

Precision and Unit. That is the reason why we recommend to set these options

immediately after the first start of the program or before entering new cutting plan.
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10.1 Formats

In this option you can set Type, Precision and Unit for Length format of materials.

Type

Decimal e.g. 123,324 mm; 234,34 m; 142,2"

Feet and decimal inches e.g. 833' 3,99"

Fractional e.g. 324 31/32"

Feet and fractional inches e.g. 1302' 63/64"

Precision

Here you can set the precision of entering the length format (decimal places, fractions)

according to setting of the type.

Unit

Here you can set the length unit of material (mm, cm, dm, m, '', '). This option is accessible

only when the decimal or fractional type is set. When other types are set, this option is

disabled. Defined Unit is shown in the length of material in the program and also in

printing reports.

Tip: You can also set your own length unit by writing it to combo box or you don't

need to fill it in at all. In this case the length unit won't be shown.
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Note: Because for each length format internal storage of data is different, change of

length type and precision doesn't convert already entered data. Therefore, it is

necessary to consider this option carefully at the beginning of working with this

program.

Zero suppression

Leading Suppresses displaying of leading zeros in decimal numbers.

Trailing Suppresses displaying of trailing zeros in decimal numbers.

0 Feet Suppresses displaying of 0 feet.

0 Inches Suppresses displaying of 0 inches.
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10.2 General

Here you can set visibility of closed/opened plans, stock cost check and optimization

level.

Plans visibility

Here you can set limit of days to show closed/opened plans according to plan creation

date. Closed/opened plans older than entered number of days will be hidden.

Plan stock costs check

You can also define maximal ratio between the highest and the lowest cost of stock within

the plan. If this ratio is exceeded, following warning message appears.



40

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Program Options

Optimization

In this option you can set the efficiency of optimization according to the running time

(speed) of finding the best solution (cutting layouts).

Fast optimization Good results with the high speed of optimization.

Normal optimization Better results with middle speed of optimization.

Deep optimization The best results with low speed of optimization.

Note: The higher optimization level you set, the more time program needs for the

optimization of a project.
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10.3 Automation

Here you can set operations which will be executed automatically every time you create

or optimize plan.

Load marked inventory stocks to plan

Never Program will not automatically loaded stocks.

Upon plan creation When new plan is created, all marked inventory stocks of

given material will be loaded to plan.

Before plan optimization Before running plan optimization, all marked inventory

stocks of given material will be loaded to plan. 

Close plan after optimization

Plan will be automatically closed after optimization and used stocks will be counted off

the inventory.
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10.4 Sorting

In this option you can set sorting of cutting layouts and cutting layout parts. Each of this

data can be sorted by three different fields in individual ascending or descending order.
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10.5 Layout pictures

In this option you can set some properties for the displaying of layout pictures in program

and reports.

Layout pictures in program/reports

Compact display of parts Grouped parts with the same size have only one common

info, otherwise each part has its own information.

Center part info Part information is centered, otherwise is aligned left.

Display cutting coordinates

All Coordinates are shown for each part size.

Only at size change Coordinates are shown only for new part size.

None None coordinates are shown.

Part info

Following text describes how to enter expression for part info in layout pictures. It is

possible to enter any text and variables.
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Variables

Every variable starts with @ and it is possible to enter following variables.

@PartID Part ID

@PartNum Part #

@Len Part length

@RoughLen Part rough length

@OrdNum Order #

@Desc Description

@Note1 Note 1

@Note2 Note 2

Colors

Here you can set individual background color for Layouts, Parts, Remnants and Scraps in

program and reports.

Fixed Color is defined by user and is the same for each part.

Colored Colors are defined by user individually for each part. 

Shades of gray Shades of gray for parts are generated by the program.

Click button [Load default] if you want to load default settings.
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10.6 Serial port

Here you can set serial port, and how data are sent to it. You can send to serial port data

exported via Custom Exports module, or cutting layouts of one plan or multiple selected

plans via "File > Export > Send cutting layouts to serial port".

Serial port settings

Click on the button to pick serial port and set baud rate and other settings.

Prefix

A prefix that is added to the beginning of data sent to the serial port. Can include control

char sequence, for example #9 (tab).

Suffix

A suffix that is added to the end of data sent to the serial port. Can include control char

sequence, for example #13#10 (line break).

Show button on Results tab

Check if you want to show button on Results tab for quick access. You can send cutting

layouts to serial port also via File > Export menu.
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11 Plans

To work with Plans, click the button  in the main toolbar or select the menu item "File

> Plans" or press Ctrl+1.

Plans are the main part of the program where you can enter, optimize and manage

cutting plans. Each plan consists of stocks (material to cut from), parts (pieces to cut),

settings (cutting parameters and restrictions), and optimized cutting layouts.

You can create new cutting plan in one of the following ways.

• Adding new plan directly

• Copying existing plan

• Adding multiple plans using Assemblies

• Adding multi-material plans using import

47
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11.1 Adding new plan directly

To add a new empty cutting plan, first click the Plans tab to open Plans form. Next, click

the button  in the data navigator to add a new plan.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Date Plan creation date.

Material Type of material. This field is mandatory. If you do not use Inventory

features you can leave this field without editing and "Default" material is

set automatically. "Default" material is predefined in the program and

can not be deleted from Materials. The field is red if material Stock level

< Min. level. See more in chapter Stock level control .

Description Short description.

Name Name.

Note 1 Additional description.

Note 2 Additional description.

Note 3 Additional description.

Note 4 Additional description.

Uncut Number of uncut parts.

Parts Number of parts.

Stocks Number of stocks used.

Cost Overall cost of the project.

98
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Yield Achieved material utilization in percentage.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

Important: You can define as many plans as you need for one material. However, one

plan may contain only one material.

Once you added new plan, you can start defining its stocks  and parts .

33
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11.2 Copying existing plan

You can add new plan by copying the existing one. First, select the plan you want to copy

by clicking on it. Then click the button  in toolbar and choose an option from the

pick list as is shown in the following picture.

Plan It will copy only related data from Plans tab and also defined

parameters from Settings tab of selected plan into a new

plan. 

Plan and stocks It will copy related data from Plans tab and defined

parameters from Settings tab and all stocks defined in Stocks

tab of selected plan into a new plan.

Plan and parts It will copy related data from Plans tab and defined

parameters from Settings tab and all parts defined in Parts

tab of selected plan into a new plan.

Plan, stocks and parts It will copy all related data from selected plan into a new plan.
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11.3 Adding multiple plans using Assemblies

Entering multiple plans using Assemblies is a very useful feature decreasing your effort in

the moment when you need to prepare all plans for all materials defined in one assembly.

It enables you to prepare all plans in one turn.

First, select assembly you need to prepare multiple plans for.

Next click  button and select [Copy to plans / create plans].

Unique batch identifier is automatically generated. You can use this one or rename the

batch as you need.
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Tip: You can use one Unique batch identifier for as many Assemblies as you need.

When creating Multi-material plan for next Assembly simply use the same Unique

batch identifier as for the first Assembly. This approach leads to better yield and

better labor organization.

Confirm the dialog.

Here you can change repetition of copied assemblies. The original quantity of parts  will

be multiplied by entered value. Confirm the dialog to create plans.
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11.4 Adding multi-material plans using import

This chapter describes creation of multi-material plans by importing parts made from

different materials at once. First of all, you have to prepare such import data, as is

demonstrated in the following image.

Important: Be sure that you have already created kinds of material you want to

import to Inventory. Undefined materials can not be imported.

Note: This demo demonstrates import from clipboard. However, there are other kinds

of import presented in chapter Import , which can be used too.

Copy parts to clipboard , open Plan parts tab (there is no need to create a new plan

manually in this case) and press Ctrl+J to open Import window.

113

117
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Map all relevant data fields and click the [Import] button. Following information dialog

appears.

Confirm [Yes] and fill in the information in the batch import dialog (at least plan

description).
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Confirm [OK] and program automatically creates multi-material plans from imported

parts.

Now you can enter stocks you want to cut from, and run the optimization.

Tip: If you want to optimize more plans at once (also with different materials) select

these plans and run the optimization. See more in chapters Data multiselection

and Running optimization .

31
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11.5 Running optimization

When all the information needed for the plan is defined (stocks, parts, settings), you can

start to perform the optimization of cutting layouts.

To start calculation of cutting layouts for the current plan, click the button  in main

toolbar. You can also run optimization directly by pressing F3 or by selecting "File > Start

optimization" from the menu. You don't have to switch to Results form, the program does

it automatically. During the optimization, you can watch its progress and the best results

which are achieved.

You can stop optimization process at any time by clicking the button  in the main

toolbar or by pressing Esc. In such case following confirmation dialog appears.

If you click the button [Yes], program will stop the optimization and the values will be

saved to the plan. Previous results will be overwritten by values which were found in the

moment the optimization process was interrupted. If you click the button [No], the
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optimization will stop and previous results will be left without any change. Values which

were found during this last optimization will be ignored. If you click the button [Cancel],

the optimization will continue.

When optimization is finished, the best cutting layouts will be automatically entered to

the plan. The cutting layouts which were saved the last are always stored for next potential

use (additional printing of reports, statistics, etc.).

Tip: When you choose particular plan in Plans form and you click the Results tab, you

can immediately go over cutting layouts and summary of data which were saved the

last.

Tip: If the achieved results fulfill your needs and the optimization is not finished, you

can stop it and use these results in the plan.
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Layouts

Following data grid shows the cutting layouts which were calculated by the program and

user is immediately able to see their overview.

Summary

Here are complete information about the progress of calculation and currently achieved

values of an active project (Cost, Yield, Gross yield, Stocks, Parts, Layouts, Uncut parts).

Column 1 Column 2 Column 3

Cost - Overall cost of the plan.

Yield Achieved utilization in percentage

taking into account produced

remnants.

[Sum length of used parts / (Sum

length of used stocks - Sum length

of produced remnants)]

Absolute value of achieved

utilization taking into account

produced remnants.

[Sum length of used stocks - Sum

length of produced remnants]

Gross yield Achieved utilization in percentage

not taking into account produced

remnants.

[Sum length of used parts / Sum

length of used stocks]

Absolute value of achieved

utilization not taking into account

produced remnants.

[Sum length of used stocks]

Stocks Number of stocks used in

calculated cutting plan.

[Sum length of used stocks]

Parts Number of parts used in calculated

cutting plan.

[Sum length of used parts]

Layouts Number of layouts of calculated

cutting plan.

-



58

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Plans

Uncut parts Number of uncut parts (not used

parts) in calculated cutting plan.

[Sum length of uncut parts]

Layout

Graphical representation of the layout which is currently selected.

Tip: After double click on part or remnant, associated report is printed (e.g. label

report). See more in Reports .
101
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11.6 Refining optimization

What is it?

CutLogic 1D contains very unique OptiRefine module providing an intelligent

optimization refinement and re-optimization based on different priorities. As mentioned

above, CutLogic 1D optimizer is based on cost optimization, in other words cost is the

major priority for optimization. However, in some situations you may have different

priority than the cost or you may have more priorities simultaneously. For example,

imagine cutting case where cost of material is relatively low but cost of preparation phase

for new cutting layout is relatively high. In such case the priority is to find solutions with

minimal numbers of cutting layouts in parallel with minimal waste. 

During optimization, the program identifies hundreds of possible solutions and chooses

the best one. This solution, however, might not suit you and your requirements. With help

of OptiRefine you can directly find the right one.

Priorities of optimization and their relations create such large number of combinations

and mutual continuities, that the only way to find the most suitable solution is to use

OptiRefine.

OptiRefine is based on Fuzzy Logic and together with the optimization module which

uses Genetic Algorithms makes of CutLogic 1D the most advanced and progressive

application built on the two of three main techniques of modern Artificial Intelligence.

What is it for?

During the optimization the program identifies a set of possible solutions and chooses

the one which fulfills these requirements (classified according to importance):

• Minimal count of unused cut-to parts

• Minimal total price of used cut-from stocks

• Maximal utilization

• Maximal count of used cut-from stocks (decreases the number of shorter stocks,

reusable off cuts from previous plans, etc.)

• Maximal length of the last rest (transfer of waste to the last rest, which can be used in

the next plan)

• Minimal number of cutting layouts
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Let’s imagine the solutions of cutting plan according the following table.

Yield No. of used stocks No. of cutting layouts

Solution 1 99.79% 511 35

Solution 2 99.78% 510 12

Solution 3 99.14% 512 6

Solution 4 99.39% 1207 33

Solution 5 99.63% 840 20

CutLogic 1D automatically chooses the solution No. 1, because of the best yield result.

Better for you might be, however, the solution No. 2 which has a little bit lower yield, but

less cutting layouts. This means lower labor expenses. Solution No. 3 has small number of

cutting layouts, but yield is too low.

You can also prefer solution No. 4, which has low yield and a large amount of cutting

layouts, but it includes the highest number of used stocks. It means that you get rid of the

remnants from previous plans.

Note: Another choice how to use the remnants stocks preferable, is to give them

lower price per length unit.

Or maybe you will choose solution No. 5 - although its all three values are not the best,

each one of them is good enough.

Whichever mix of preferences, you can formulate it simply by changing priorities and

watching the list of solutions sorted by their fitness, which is generated online with every

change in priorities you do.

Tip: OptiRefine enables to choose any solution in the most convenient and accurate

way.
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How to use it?

After the optimization finishes, new tab OptiRefine is added to the Plans.

OptiRefine consists of a table of solutions and optimization priorities. You can survey

possible solutions in the table of solutions. A click on the title of the column will classify

the list according to the given column. With the click on the  button, you will

choose the current solution so that the final cutting plan will be equal to this solution.

There are several possibilities of application in the module of OptiRefine.

• You can manually find the best solution in the table of solutions (button 

appoints the found solution).

• You can change given priorities and view the changes in the table of solutions online.

What is more, you can change the marginal values (Best value and Worst value) for

individual optimization priorities. (button  appoints the found solution).

• You can even set the optimization priorities and start the re-optimization process by

clicking the button . So you can get the values which will precisely fulfill your

intentions. After finishing the re-optimization, you can either accept the found solution

or find another one by using one of three OptiRefine methods.
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Examples of using

Example 1

You want the number of cutting layouts to be lower than 21, the lower the better.

For Layouts set Worst value at 21, Best value at 1 and Priority at 500. If there isn't a

suitable solution in the Cutting plans, you can start the re-optimization with a click on the

button .

Example 2

You want the number of cutting layouts to be lower than 21 and it doesn't matter how

small this number will be.

For Layouts set Worst value at 21, Best value at 20 and Priority at 500. If there isn't a

suitable solution in the Cutting plans, you can start the re-optimization with a click on the

button .

Example 3

You want to find a good trade-off for cost, sufficient low layout count, and number of

used stocks.

For Stocks set Priority at value little bit less than Priority of Cost.

For Layouts set Priority at value little bit less than Priority of Cost.

Watch solutions in upper lines in Cutting plans, and slightly change priorities to refine your

search.

If there isn't a suitable solution in the Cutting plans, you can start the re-optimization with

a click on the button .
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11.7 Opening and closing the plan

It is possible to close already optimized and finished plans and disable their unwanted

modification. When stocks of materials used in plans are stored stocks registered in the

Inventory, by closing the plans used stocks will be counted off the Inventory and their

count will be automatically set to real values. In case of need, it is possible to re-open

plans and modify them.

To close / open plans click the button  in Plans form. Opening and closing of

plans is described as follows.

Close plan Locks the plan so it is impossible to modify it. When stocks of materials

used in the plan are registered in Inventory, the stocks used in the plan are

automatically removed from dedicated Material and Storage. Reusable

remnants are added to dedicated Materials and Storage as new stocks.

The length of reusable remnants is set in Settings of plan.

Open plan Opens the plan so it is possible to modify it. By opening the plan the

changes (made when the plan was closed) are restored to its original state.

Stocks levels are readjusted according to real state before closing of the

plan and reusable remnants added to Stocks are removed.
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12 Plan stocks

When general information about the plan is entered, you can start to enter the stocks

(material available to cut from), one of mandatory input for the optimization.

You can enter stocks in one of the following ways.

• Entering stocks directly

• Copying stored or predefined stocks from Materials

• Importing stocks from external data source

Tip: It is possible to combine all above mentioned ways of entering the stocks.
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12.1 Adding stocks directly

Click the Stocks tab to open Plan stocks form. To add new cutting stock, click the button

 in the data navigator.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Length Length of stock.

Qty Quantity of available stocks. Unlimited quantity represents pre-defined

or virtual ones. Such stocks are not part of your real inventory.

Used Non editable field informs you about number of stocks planned by

optimizer to be used for cutting.

Cost Stock cost (e.g. "75.00 / pc" or "8.20 / L4", etc.).

pc = cost of the whole piece

L1 = cost of 1 length unit

L2 = cost of 10 length units

L3 = cost of 100 length units

L4 = cost of 1000 length units

L9 = cost of 12 length units

Cost/pc Calculated cost of the whole piece (read only).

Description Short description of stock. 

Storage Non editable field represents physical storage where the stocks used in

the plan are stored. Applicable only for stored stocks loaded from

Inventory.

Mnf. date Manufacture date (all created remnants have the same manufacture date

as their original).

Note 1 Additional description of stock.
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Note 2 Additional description of stock.

Note 3 Additional description of stock.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

Tip: How to use CutLogic 1D for estimation of optimal quantity of stocks in the plan?

If you know what parts you want to cut, what dimensions of stocks can be used, but

you do not know how many stocks of given length you should order, just select

unlimited value in the field Qty. Program will automatically find optimal usage of

that stock during optimization. Consequently, you can order only the material you

need for the plan and you don't need to keep material in storage.

Important: You can leave field Cost blank – this is not mandatory field for

optimization. CutLogic 1D optimizer is based on cost optimization – it means the

optimizer is trying to find "the cheapest" cutting plan (layouts). In the case when

"Cost" fields are blank or contain the same value for all stocks within given plan – in

other words if cost priority is not used – we talk about yield optimization which is a

special case of cost optimization. In such case optimizer finds optimal cutting plan

with the maximal yield and minimal physical waste. Because of the same cost of all

stocks it is also the cheapest cutting plan. In case when you set different costs for

different stocks the optimizer finds the cheapest cutting plan, which isn't necessarily

the plan with maximal yield/minimal waste.

Tip: You don't need to assign the real cost to the Cost field. Cost field can be also

understood and used as a priority – stocks with lower cost are used in optimization

process with greater priority.

33
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12.2 Copying stocks from Materials

The second way how to enter stocks to the plan is to load them from Materials.

By clicking the button , the Material stocks form with predefined stocks opens.

You can mark one or more stocks and copy them to plan by clicking the button .

Tip: Click the button  or press Ctrl+M to mark/unmark selected/all stocks.

After clicking the button  following confirmation dialog appears.

After confirming the dialog, the stocks are copied to the plan.
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Important: Keep in mind that stocks with defined quantity represent real stocks of

real Inventory and you can not edit them in this form, while stocks with "unlimited"

quantity represent predefined stocks – templates. Such kind of stocks is virtual one

and it can not be stored in Storages so that Storage field is blank. You can edit and

change the same fields as in manual mode of entering the stocks.
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12.3 Importing stocks from external data source

The third way how to enter the stocks to the plan is to import them from the external data

source.

It is possible to import stocks from any of following structured files: TXT, CSV, MS Excel

file, MS Access file, from clipboard or from an external database via connection string

definition.

You can import stocks from external source by clicking the menu "File > Import" or by

pressing Ctrl+I/Ctrl+J. Read more about import in chapter Import .
113
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13 Plan parts

When all stocks are entered, you can start to enter parts you want to cut.

You can enter parts in one of the following ways.

• Adding parts directly

• Copying predefined parts from Materials

• Copying predefined parts from Assemblies

• Importing parts from external data source

Tip: It is possible to combine above mentioned ways of entering the parts.

71
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13.1 Adding parts directly

Click the Parts tab to open Plan parts form. To add a new cutting part, click the button

 in the data navigator.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Length Length of part.

Rough len. Part length taking into account cutting setting "Part increase".

Qty Quantity of parts.

Uncut Number of parts unable to be cut or manually withdrew from the layout.

Description Short description of part.

Order # Order number.

Note 1 Additional description of part.

Note 2 Additional description of part.

Note 3 Additional description of part.

Color Color of part. To define or change it, click on particular color cell. Tab

with following color picker will be shown.
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To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".
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13.2 Copying predefined parts from Materials

If you often use the parts with the same parameters, you can predefine them in Material

parts. Whenever you need them, you can copy them into the plan.

By clicking the button , the form Material parts with predefined parts opens.

You can mark one or more parts and import them to the plan by clicking the button

.

Tip: Click the button  or press Ctrl+M to mark/unmark selected/all parts.

After clicking the button  following confirmation dialog appears.

Here you can change repetition of copied parts. The original quantity will be multiplied

by entered value.
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After confirming the dialog, the parts are copied to the plan.
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13.3 Copying parts from Assemblies

Assemblies enables you to define multi part products in Inventory and to work with

them. Parts in Assemblies represent bill of material for given end product. Working with

assemblies simplifies preparation work when defining new cutting plan. When preparing a

new cutting plan for given material you can copy all Assemblies containing parts made

from given material to the plan.

Example

You are preparing plan for material U 40x3 mm because your customer ordered 20

ladders from your catalog.

First, have a look at how the parts of Ladder are defined in the Assemblies.

Note: Notice that assembly Ladder contains parts made from different material, so

that you have to prepare separate cutting plan for every material in order to cut all

needed parts. To have created multi-material plans by program see Adding multiple

plans using Assemblies .

Now you can define cutting plan for material U 40x3 mm and copy related parts to the

plan by using Assemblies. Define a new plan and click Parts tab.

Next click the button  to open Assembly parts form. Then click the button

 to select all parts for copying into the Plan parts form and click the button

.

Following popup menu appear.

Select [Copy to current plan].

50
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Enter number of assemblies - in our demo case we want to cut parts for 20 Ladders - and

confirm the dialog.

Note: Notice that only matching parts with the same material as defined in given

plan will be copied. See Entering multiple plans using Assemblies  if you want to

create multiple plans from Assembly.

50
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13.4 Importing parts from external data source

The fourth way how to enter the parts to the plan is to import them from the external

source.

It is possible to import parts from any of following structured files: TXT, CSV, MS Excel file,

MS Access file, from clipboard or from an external database via connection string

definition.

You can import parts from external source by clicking the menu "File > Import" or by

pressing Ctrl+I/Ctrl+J. Read more about import in chapter Import .
113
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13.5 Part splitting

In case, when your real parts are longer than stocks and your manufacture technology

enables you to join small fragments together (welding, gluing, etc.), you can split these

long parts before optimization. To split parts, go to Plan parts tab, select  desired parts

(to select all, press Ctrl+A) and choose the menu item "Edit > Split part". Following Split

part dialog appears.

Split part to fragments with length All selected parts will be split into fragments

with this value.

If last fragment is smaller Determines, what to do with the last part

smaller than desired value (Nothing, Round it

up, New length).

Delete part fragments created before All part fragments that were created before

will be deleted. 

Example

Material Stocks (Length x Qty) Parts (Length x Qty)

Square steel 4,000 x Unlimited (usual size from supplier) 12,400 x 10

1,200 x 12 (remnants) 11,300 x 8

6,200 x 12

31
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As you can see when you run optimization, it is not possible to optimize such plan

because of too large parts.

Solution is to split these parts. Select all parts (Ctrl+A) and choose the menu item "Edit >

Split part". Enter desired length (in our case 4,000) and press "Split" button. Parts are split

into following fragments.
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As you can see, all part fragments have the same Part # as their original part and are

recognized via this number. Now it is possible to run optimization. Following diagram

demonstrates optimized plan.

After optimization of cutting plan which includes split parts, UI and "Cutting layouts"

report show how to cut material to get part fragments. After the part fragments are cut,

you need to put them together and join them to get final parts.
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14 Plan settings

Here you can define the Settings for the plan. 

There are two ways how to define Settings.

• Entering parameters directly

• Copying predefined Settings from Materials

Tip: It is possible to combine above mentioned ways of entering the Plan settings,

however keep in mind all consequences.

82
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14.1 Entering settings directly

Click the Settings tab to open Plan settings form.

Settings tab enables you to define cutting settings for given plan.

Kerf Width of cut.

Left trim Left unusable stock margin.

Right trim Right unusable stock margin.

Part increase Value, which will be added to each side of part.

Grip Size of material required for grip. Gripping portion

of stock can be utilized in case when length of part

is the same as length of the rest of stock, so no

cutting and gripping is needed. For example if

Gripping is 23 then rest can be 0, or 23, or greater

than 23.

Allow grinding When allowed, rest of stock can be shorter than cut

width (kerf) so the last part is not cut but it is only

grinded to required length. When off, material

remaining after the last part in the layout will be

either zero or not smaller than kerf.
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Minimize layout count Minimizes number of cutting layouts and overall

labor (may cause lower yield). This feature is

interesting in cases when setting of your cutting

machine is too expensive or requires much time to

preset. Keep in mind that when you use this option,

the yield of your material is lower.

Max number of stock lengths Optimizer will not use more stock lengths than this

value.

Min layout repeat Optimizer tries to find cut plan in which each layout

repeats at least this value times.

Max number of parts in layout Limits total number of parts in each cutting layout.

Max number of different part

lengths in layout

Limits maximum number of different part sizes in

each cutting layout.

Min length difference among parts

in layout

Size difference between each two parts in layout

will be zero or bigger than this value. Example:

Required parts: 5cm, 7cm, 9cm, 11cm, 12cm, 14cm,

18cm and min length = 3cm then following parts

could be together in one layout: 5,9,12,18. If min

length = 5 cm then following parts could be

together in one layout: 5,11,18 or 7,12,18, etc.

Min remnant length Minimum length of reusable remnants. Function

Close plan will move rests with length greater or

equal to this value to defined Storage for new

rems. Function Open plan will remove these

remnants from inventory.

Storage for new rems Storage where newly created remnants will be

stored upon plan closure. Function Close plan will

move rests with length greater or equal to Min

remnant length into this storage as remnants.

Function Open plan will remove these remnants

from this storage.

Rem. production rate Number between 0 and 99; the bigger the number,

more remnants are produced which results in a

better yield. Note: weighted production of remnants

positively affects the yield and decreases scrap

factor.

Don't create rests with length

between...

Optimizer tries to avoid creation of rests with length

in this range.
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Tip: Set Max number of parts in layout to 1 to allocate cables (parts) to reels

(stocks).

Note: Some of parameters are available only in professional edition or in enterprise

edition. See chapter Edition comparison  for details.
13
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14.2 Copying predefined settings from Materials

If you often use the same settings for new plans or if you want to setup different settings

for different cutting machines, you can predefine them in Material settings. Whenever you

need it, you can load them to the plan.

By clicking the button , the Material settings form opens.

You can choose setting from predefined settings list and write it to the plan. To copy

chosen setting to the plan, click button  or press F4.
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15 Inventory

Inventory is a complement part of the program. It is used for inventorying and overall

easy work with the program. You can keep here types of materials and their stocks and

you can also define the storages where the stocks are actually placed. You can define

Assemblies in order to save time and simplify working with plans.

The Inventory enables you to track physical material (from inventory to plans and vice

versa), run physical inventory and more.

See chapter Opening and closing the plan  for related consequences.

Inventory consists of these three parts:

Materials

Assemblies

Storages

63
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15.1 Materials

To work with Materials, click the button  in the main toolbar or select the menu item

"File > Inventory > Materials" or press Ctrl+2.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Description Short description.

Thickness Thickness of material. Useful for some Machine settings.

Stock level Sum length of all stocks of actual material. The field is red if Stock level

< Min. level.

Min. level Minimum stock level. See more in chapter Stock level control .

Above level Calculated value of above stock level (Above level = Stock level - Min.

level). The field is red if Stock level < Min. level. This column is hidden

by default, you can make it visible in columns rearrangement form .

Note 1 Additional description.

Note 2 Additional description.

Note 3 Additional description.

Note 4 Additional description.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

98
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Click the Materials master tab to add new material and/or change descriptive

information about existing materials. When new material is added you can continue in

defining of stocks, parts and cut settings.

Stocks tab

Click the Stocks tab to define stocks of actually set material. These stocks are your real

inventory and you can associate them to the specific Storage through the field Storage. If

no Storage is defined, default storage will be used implicitly.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Length Length of stock.

Qty Quantity of available stocks. Unlimited quantity represents virtual ones.

Such stocks are not part of your real inventory.

Cost Stock cost (e.g. "75.00 / pc" or "8.20 / L4", etc.).

pc = cost of the whole piece

L1 = cost of 1 length unit

L2 = cost of 10 length units

L3 = cost of 100 length units

L4 = cost of 1000 length units

L9 = cost of 12 length units

Cost/pc Calculated cost of the whole piece (read only).

Description Short description of stock. 

Storage Storage where the stock is stored.

Mnf. date Manufacture date (all created remnants have the same manufacture date

as the stock they were cut from).

Note 1 Additional description of stock.
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Note 2 Additional description of stock.

Date Is automatically filled-in when stock is entered or remnant is created.

Origin ID When defining a new stock, Origin ID is automatically set by program

and is equal to stock ID displayed in data grid. All remnants inherit

Origin ID from stock they were cut from. It is extremely useful for

tracking purposes of given material from original stock through sub-

stocks or remnants to final parts.

Plan ID Plan identification number, in which remnant was created.

Mark Determines which stocks can be copied to plan.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

Note: Stocks which are defined in Materials are your real inventory. When you define

and use them, you get a transparent overview of movement of materials and overall

inventory in Storages.

Tip: It is possible to import stocks of materials from any file with any structure or

from clipboard.

Parts tab

Click the Parts tab to define parts for given material. Defining of parts in Materials can be

useful in cases when these predefined parts are frequently used in plans, so that copying

these parts from Materials may save time and simplify preparation of new cutting plan.

33
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Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Length Length of part.

Qty Quantity of parts.

Description Short description of part.

Order # Order number.

Note 1 Additional description of part.

Note 2 Additional description of part.

Mark Determines which parts can be copied to plan.

Color Color of part. To define or change it, click on particular color cell. Tab

with following color picker will be shown.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

33
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Settings tab

Settings tab enables you to define list of pre-defined plan settings for given material. See

more in chapter Entering Settings for the Plan .
81
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15.2 Assemblies

Working with Assemblies enables you to define assemblies (products) and their parts.

When defining a plan(s), it is possible to copy entire assemblies into given plan(s). It can

be also used to store orders from your customers and using these you can create a new

plan or multiple plans. It brings simplification and streamlining to your work. See chapter

Entering multiple plans using Assemblies  for more information.

Tip: You can use Assemblies to collect and record your orders and according to them

create new plans.

To work with Assemblies, click the button  on the main toolbar or select the menu

item "File > Inventory > Assemblies", or press Ctrl+3.

Assemblies tab enables you either to define new assembly and related descriptive

information or to edit existing ones.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Date Assembly date. Alternatively it can be also used as order date.

Description Short description. Alternatively it can be also used as order description.

Note 1 Additional description.

Note 2 Additional description.

Note 3 Additional description.

Note 4 Additional description.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

50
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Parts tab

Parts tab enables you to define parts for given assembly. Parts in assemblies represent bill

of materials or customer orders. This is new point of view on how to work with parts. It can

be very useful in cases when you prepare cutting plan with many assemblies or orders.

This feature brings time saving and simplifies preparation of the new cutting plan.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Length Length of part.

Qty Quantity of parts.

Description Short description.

Material Type of material.

Order # Order number.

Note 1 Additional description.

Note 2 Additional description.

Mark Determines which parts can be copied to plan.

Color Color of part. To define or change it, click on particular color cell. Tab

with following color picker will be shown.
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To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

33



95

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Inventory

15.3 Storages

To work with Storages, click the button  in the main toolbar or select the menu item

"File > Inventory > Storages", or press Ctrl+4.

Storages tab enables you to define your storages where your material is kept. Storage

numbered 1 is pre-defined storage (Default) and it is not possible to delete it. You can

change its Description for better customizing. If you don't define other storage when

defining plan, pre-defined storage (Default) will be used.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Description Short description.

Note 1 Additional description.

Note 2 Additional description.

Note 3 Additional description.

Note 4 Additional description.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

33
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Stocks tab

Click the Stocks tab to view or define stocks of currently selected Storage. These stocks

are your real inventory and you can associate them to the concrete Material through the

field Material.

Columns

No. Record number.

ID Unique identification number generated by program.

# User defined identification number.

Length Length of stock.

Qty Quantity of available stocks. Unlimited quantity represents pre-defined

or virtual ones. Such stocks are not part of your real inventory.

Cost Stock cost (e.g. "75.00 / pc" or "8.20 / L4", etc.).

pc = cost of the whole piece

L1 = cost of 1 length unit

L2 = cost of 10 length units

L3 = cost of 100 length units

L4 = cost of 1000 length units

L9 = cost of 12 length units

Cost/pc Calculated cost of the whole piece (read only).

Description Short description. 

Material Type of material.

Mnf. date Manufacture date (all created remnants have the same manufacture date

as their original).

Note 1 Additional description.

Note 2 Additional description.

Date Additional date.
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Origin ID When defining a new stock, Origin ID is automatically set by program

and is equal to stock ID displayed in data grid. All remnants inherit

Origin ID from stock they were cut from. It is extremely useful for

tracking purposes of given material from original stock through sub-

stocks or remnants to final parts.

Plan ID Plan identification number, in which remnant was created.

To rearrange columns , their order and visibility, click the button  in data grid or

select the menu item "View > Rearrange columns".

33
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15.4 Stock level control

You can manage your material stock level by filling the Min. level field in the Materials.

This value determines minimum total length of stocks you want to keep on the storage to

achieve maximum fluency of the production. If minimum stock level is lower than real

stock level, it is immediately indicated in the grid highlighted in red color. This informs

you, that you need to order and store additional material stocks.

Following images show state which is under minimum level of stocks in the Materials and

also in the Plans.
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16 Reports

Reports is an important part of the program, where you can print or preview any data

(cutting layouts, lists, labels, etc.) displayed in printable format. It is possible to choose

from predefined reports, or you can create new ones (customized data views, statistics,

etc.). See more in Report creating .

Following list represents predefined reports divided into groups according to active

section (Plans, Materials, Assemblies, Storages).

Plans

Cutting layouts Optimized cutting layouts.

Plans List of plans.

Plan stocks List of plan stocks.

Plan parts [grouped by sorting] List of plan parts grouped according to

sorting fields (when sorting  is applied). 

Labels - Cutting layout parts Labels of cutting layout parts.

Labels - Cutting layout remnants Labels of cutting layout remnants.

Labels - Plan parts Labels of plan parts.

Materials

Materials List of materials.

Material stocks List of material stocks.

Material stocks [grouped by storages] List of material stocks grouped by storages

(when various storages are used).

Material parts List of material parts.

Labels - Material stocks Labels of material stocks.

Assemblies

Assemblies List of assemblies.

Assembly parts List of assembly parts.

Storages

Storages List of storages.

Storage stocks List of storage stocks.

Storage stocks [grouped by materials] List of storage stocks grouped by materials

(when various materials are used).

Labels - Storage stocks Labels of storage stocks.

106
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Note: It is possible to apply both, filter  and data multiselection , to prepare the

reports.

28 31
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16.1 Report window

Here you can manage (print, export, preview, create, copy, edit, delete) all available

reports and also set printer for each report. Program displays reports relevant to currently

active section (Plans, Materials, Assemblies or Storages).

To work with Reports, click the button  on the main toolbar or select the menu item

"File > Reports" or press Ctrl+P.
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Main bar

The main bar is a collection of four speed buttons providing quick access to commonly

used commands.

Prints selected report.

Shows print dialog (where you can select printer, set number of copies,

print mode, etc.), and then prints selected report.

Shows preview of selected report.

Exports selected report (data) to PDF file,  Excel file, Word file, RTF file,

ODT file, ODS file, CSV file, HTML file or sends report as an email. Read

more about export in chapter Export .

Data navigator

Data navigator serves for navigation and editing of reports displayed in data grid.

Function of the buttons of navigator is following.

Moves to the first report.

Moves to the previous report.

Moves to the next report.

Moves to the last report.

Creates a new empty report / a copy of selected report. See more in Report

creating .

Deletes the current report (system reports cannot be deleted).

Opens embedded report editor enabling you to modify current report (system

reports cannot be modified, however copies of system reports can be fully

modified). See more in Report editing .

Posts changes made in the header of the current report (fields No., #, Report name,

Flag) to the database.

Cancels changes made in the header of the current report (fields No., #, Report

name, Flag).

126
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Data grid

Serves for setting and managing of reports.

Columns

No. Record number.

# User defined identification number. Click on column header # to sort

reports by numbers.

Report name Short description of report.

Flag Printing flag which can be assigned to each report.

"P - Print after double click on part" - When you double click on part in

the cutting layout image (Results tab), report with assigned P flag is

immediately sent to printer.

"R - Print after double click on remnant" - When you double click on

remnant in the cutting layout image (Results tab), report with assigned

R flag is immediately sent to printer.

To rearrange columns , their order and visibility, click the button  in data grid.

Tip: Double-click the chosen report or press Enter to preview it immediately.

33
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Printer setting for selected report

By clicking the button , it is possible to set printer and appropriate paper size to

selected report. This setting is tied to "Computer name", "Report name" and/or "User

name". It means that every CutLogic workstation on the network enables (if it is necessary)

to print current report on different printer, without changing printing options (avoiding

frequent changing of printer).

Tip: Setting printer to each computer and user individually can be very useful feature

when multiple CutLogic workstations share CutLogic database over network,

especially on thin client architecture networks such as Citrix and Terminal Services.

Important: Assigning printer to each user individually is possible only when CutLogic

is switched to network database mode.
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Options

Date

Some reports can be filtered by creation or manufacture date. You can set range of date

(Date From - Date To) you want to print.

Tip: If you want to build your own reports using SQL (Structured Query Language),

you can apply date parameters as "DateFr" (Date From) and "DateTo" (Date To) in

your scripts.

Label copies (0 for data value)

Here you can set number of copies of printed labels. By default (if set to 0), program

prints for each label as many copies as defined in quantity field (Qty) of printed dataset. If

you set custom copies number (1-500), each label is printed that value times.

Start printing first label on position

Here you can set start position (1-200) from which you want to print first label of the

current labels dataset. The order of printed labels is "Top to Bottom" and "Left to Right",

as you can see in the following layout.
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16.2 Creating

To create a new empty report (or a copy of selected one), click data navigator button 

 or press Insert. Popup menu with the following options appears.

Create copy of report Creates copy of selected report and opens report editor.

Create new regular report Creates new empty report and opens report editor.

Create new label report Creates new empty report which enables you to print

labels. After creating a report, report editor opens. See

more in Label creating .

Note: It is not possible to modify predefined (system) reports. If you would like to

change a system report, we recommend you to create a copy of this report first.

Copied (user defined) reports can be fully modified.

See also Report editing .

108
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16.3 Editing

To start working with embedded report editor, select appropriate (custom) report and

click data navigator button .

Important: Predefined (system) report cannot be edited. However, it is possible to

create a copy  of this report and edit it (professional and enterprise editions only).

Note: CutLogic 1D has a built in report editor – FastReport® generator. For details

how to work with reports (edit, print or preview) or for explanation regarding all

report settings and/or export settings please download FastReport user’s manual

from our web.
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16.4 Label creating

To create new label report, click data navigator button  or press Insert and select

"Create new report > Label report".

Label

Name Here you can enter name of new label report.

Type Here you can select type of new label report (Cutting layout remnants, Cutting

layout parts, Plan parts).

Label format

Brand Here you can set brand of label.

Type Here you can select type of label from hundreds of predefined labels.

Unit Here you can set desired units (Centimeters, Inches, Pixels).
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Creates new label format.

Starts property editor of selected label format.

Deletes selected label format.

Label format editor

By clicking button  or  following property editor is shown. Here you can

set main properties of label format.

Preview

Here you can see design of currently selected label format and its basic information (Page

size, Label size, Columns, Rows).
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16.5 Previewing

To preview selected report click the button  or double-click the chosen

report.

Following images show Cutting layouts and Labels - Cutting layout parts reports in

preview modes.
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Note: CutLogic 1D has a built in report editor – FastReport® generator. For details

how to work with reports (edit, print or preview) or for explanation regarding all

report settings and/or export settings please download FastReport user’s manual

from our web.
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16.6 Completeness flag

Sometimes you can see the sign "*" on the left of the part Description or Order # in the

Cutting layout reports (in the section layout parts). It signalizes that the batch of parts

with this value (Description or Order #) is completed and there is no next occurrence of

these parts in the cutting layouts of currently viewed plan(s).

Tip: This feature can be extremely useful when you need to speed up your

manufacture process. When you see the completeness flag, cut parts of the entire

completed order can be immediately sent to production.

You can see example in the following image.
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17 Import

CutLogic 1D provides very sophisticated and powerful features for import. Importing data

is easy and user friendly. All commonly used input formats of source files are supported in

the program. You can import data from:

• Clipboard

• Microsoft Excel file

• CSV file

• Microsoft Access db file

• Connection file

• Text file

Import of data via connection file brings unmatched versatility into CutLogic 1D and

enables you to import data from more than 40 other sources - databases, tables and files.

Note: See Edition comparison  chapter to check if desired import format or

method is available in given edition of CutLogic 1D.

117

119

121

123

125

121

13



114

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Import

17.1 How to import data

To import data, first select desired tab (e.g. Plan parts tab) and click the button  in the

main toolbar or select the menu item "File > Import > Import data from Excel, Access, CSV

or connection file" or press Ctrl+I. Following open file dialog appears.

Here you can define the path to the file containing data for import, select desired file

format and pick the desired source file from the list.

Note: To import data directly from clipboard, select the menu item "File > Import >

Import data from clipboard" or press Ctrl+J.
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Click button [OK] to confirm selected file. Following Import window opens.

Here you can define structure of imported file, map the source fields to the destination

fields and define some transformations like "Default value" or "Multiply by" in this form.

Options

First row contains field names If the first row of import file is fields information,

real field names will appear in the table of

imported data instead of Field1, Field2, etc.

Clear current data before import When checked, all data from target data grid will

be deleted before Import.

Field delimiter character Here you can set fields delimiter identical with

fields delimiter in import file. (used only for *.txt

and *.csv files)

Text definition character Here you can set text definition in field. Some text

fields, e.g. Description or Note, can contain

characters identical to "Fields delimiter character",

therefore it is necessary to define these fields.
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Data

Table Displays actual table format - structure of imported

file based on selected Options. Shows how the

fields and rows of the file are recognized.

Important for *.txt , *.csv and *.* files.

Here you can set filter for imported data. See more

about setting of filter in chapter Data filtering .

Field mapping

Destination field Shows Destination field where source field will be

imported.

Source field This is mapping field where you can set the name

of Source field, which will be imported to

Destination field. If you do not set Source field, to

Destination field won't be imported any value. For

better orientation in names of imported fields see

the data grid "Data".

Default value Enables you to define default value for cases when

values for given field are not defined (empty

values) in source file.

Multiply by Enables you to define multiply factor. It is number

by which is numeric value of given field multiplied

during the import.

Note: Program remembers field mapping for each data grid.

Note: When importing detail data, you can map master field description. In such case,

import will find the master record and assign to it respective detail(s). For example,

to import plan parts to plan with given description, map destination field "Plan".  

28



117

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Import

17.2 Import from clipboard

Importing from clipboard is very similar to importing from any text based files like *.txt,

*.csv or *.*.

Before importing data from clipboard, prepare relevant import data: in Excel, Notepad,

Word, or any other editor (spreadsheet) choose the portion of data you want to import

into CutLogic 1D, select them, then click the selected data with the right mouse button

and choose Copy in popup menu or press Ctrl+C. Data saved in this way is always at your

disposal for import.

Having prepared data in clipboard you can start with import by pressing Ctrl+J.
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Here you have to setup options in order to format source data from the clipboard to the

form suitable for the fields mapping. In our case we have activated option First row

contains field names and we have set Field delimiter character to TAB value.

Now you can start to map the source fields to the destination fields. By left click on given

"Source field" in the Field mapping table, mapping list of available source fields opens.

You can pick one source field to map it on given destination field and continue until all

mapping is finished.

When all fields are mapped, you can click the [Import] button and import is done. You

can start to work with imported data.
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17.3 Import from Excel file

If you prepare import data in MS Excel sheet ( *.xls, *.xlsx or *.xlsm ) you can import them

directly from the file.

Open Excel file you want to import from. See more in How to import data .

Select particular Sheet (in case your file consists of multiple worksheets) and click [OK].

Following Import window opens.

If needed, set up options and map all relevant data fields.

114
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When all fields you want to import are mapped, you can click the [Import] button and

import is done. You can start to work with data.
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17.4 Import from CSV file

If you prepare import data in CSV (Comma Separated Values) file you can import them

directly from the file.

Open CSV file you want to import from. See more in How to import data .

Following Import window opens.

If needed, set up options and map all relevant data fields.

When all fields you want to import are mapped, you can click the [Import] button and

import is done. You can start to work with data.

114
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17.5 Import from Access db file

Import from Access db files (*.mdb, *.accdb) is very similar to imports from any table

based files like Microsoft Excel ( *.xls or *.xlsx ).

Open Access file you want to import from. See more in How to import data .

Following Import window opens.

Now you can start mapping. In our case we have used Default value feature for field Qty

because of some source data in Access file have no values, and Multiply by column has

been set to 10 on Qty.

When all fields are mapped, you can click the [Import] button and import is done. You

can start to work with imported data.
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17.6 Import via connection file

Import via connection files extremely extends importing capabilities of CutLogic 1D.

Connection file is a file containing information how to connect to existing data source via

ODBC or OLE DB driver installed on computer where CutLogic 1D runs. Connection file is

simple text file with one line including connection definition.

Example connection file cf1.conn for Microsoft SQL Server:

Provider=SQLOLEDB; Server=myServerAddress; Database=myDataBase;

Uid=myUsername; Pwd=myPassword;

You can also define table name, for example:

Provider=SQLOLEDB; Server=myServerAddress; Database=myDataBase;

Uid=myUsername; Pwd=myPassword; TableName=Orders;

Or you can define SQL statement, for example:

Provider=SQLOLEDB; Server=myServerAddress; Database=myDataBase;

Uid=myUsername; Pwd=myPassword; SQL=select * from Orders where MaterialNo = 321

order by Length;

One more example, ODBC connection to Firebird SQL database using complex SQL

statement:

DRIVER=Firebird/InterBase(r) driver; UID=SYSDBA; PWD=masterkey;

DBNAME=myServer:C:\data\ERP.fdb;

sql=

select Orders.*, Customers.CompanyName 

from Orders

left join Customers on Customers.ID = Orders.CustomerID 

where Orders.MaterialNo = 411

order by Orders.Date

 

For more information how to define connection string for your specific data source, see

www.connectionstrings.com or contact us.
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18 Export

CutLogic 1D provides powerful features and rich functionality for export. Exporting data is

easy and user friendly. Many output formats are supported in the program. You can export

data to common or specific file formats.

Common file formats

TXT Text

CSV Comma separated values

XLSX MS Excel table

DOCX MS Word file

HTML Hyper Text Markup Language

PDF Portable Document Format

RTF Rich Text Format

ODT Open Document Format

ODS Open Document Spreadsheet

JPG You can export labels to JPG files, one file per one label

PNG You can export labels to PNG files, one file per one label

Specific file formats

RazorGage Cutting layouts for RazorGage system (CSV)

CutLogic CutLogic 1D plan exchange format

Note: See Edition comparison  chapter to check if desired output format is

available in given edition of CutLogic 1D.

Tip:If you use Fractional format, instead of Excel (XLSX) file, export to CSV file, Excel

then automatically recognizes numbers in Fractional format (as Fractions).

13
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18.1 Export to common file formats

CutLogic 1D enables you to export data to Excel file, PDF file, CSV file and other

formats . Export of common file formats is a part of Report window . You can export

any report available in given report form. You can export reports from one of following

report window available in the program:

Reports - Plans

Reports - Materials

Reports - Assemblies

Reports - Storages

To export data, first select desired section (e.g. Materials) and click the button  on the

main toolbar or select the menu item "File > Reports" or press Ctrl+P.

Select desired report from the list of available reports, set-up Options and click the

button [Export].

126 101
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Select desired export format from the list.

Tip: All mentioned file formats can be sent as an email directly from CutLogic 1D.

Check or change export settings and click [OK].
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Select the file name and directory and click the button [Save].

Note: CutLogic 1D has a built in report editor – FastReport® generator. For details

how to work with reports (edit, print or preview) or for explanation regarding all

report settings and/or export settings please download FastReport user’s manual

from our web.
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18.2 Export to RazorGage file

This kind of export enables you to export cutting layouts to simple CSV (comma

separated value) file. Format of generated CSV file is fully supported by MS Excel. To

export cutting layouts to CSV file, select plan you want to export and choose the menu

item "File > Export > Export cutting layouts to CSV file" or press Ctrl+G. If you multi-select

several plans, CSV file will include cutting layouts of all selected plans, separated by

empty lines.
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18.3 Export to CutLogic file

CutLogic file is special exchange file format enabling you to import/export plans. Each file

can contain only data of a single plan. To export plan, select desired plan you want to

export and choose the menu item "File > Export > Export plan to CutLogic file" or press

Alt+1.



132

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Custom exports

19 Custom exports

Custom exports module allows you to define and run your own custom exports. ("File >

Custom exports" or Ctrl+E)

Export name: Name of export. If some exports have same name, and one of them is

run, all will run.

Run type values:

· Manual

· Manual in menu  >  Export will be accessible also via menu "File > Exports".

· Auto after plan optim  >  Export will run automatically after plan is optimized.

· Auto after plan close  >  Export will run automatically after plan is closed.

· Auto after plan open  >  Export will run automatically after plan is opened.

Format values:

· xml (plan)  >  Export of cutting plan including cutting layouts into XML file.

· csv  >  Export to CSV file using custom SQL query.

Output file: Name of export file.

File write values:

· Rewrite  >  Output file is rewritten by export data.

· Append  >  Export data are appended to output file.



133

CutLogic 1D 
 
                                                                                                                                                                                                                                                                             © 2024 TMachines

Custom exports

· Append and empty line  >  One empty line and export data are appended to output

file.

· Rewrite and empty line  >  If multi-selected data are exported, each data block will be

followed by empty line.

  

Private: If multiple users share same database over LAN, each can make his exports

private, non-visible to other users.

Options:

· Run  >  Export will run third party app or batch file, for example Run=c:\mybatch.bat.

Options (for csv exports):

· Delimiter  >  Field delimiter.

· Quote  >  Quotation mark used to quote fields which include delimiter. To quote each

field, double the quotation mark, for example Quote="".

· Header  >  0 - export will not include field names, 1 - field names will be included

once, 2 - field names will be included for each block appended

· BOM > 0 - export file will not include BOM (Byte Order Mark), 1 - BOM will be

included. If CSV file contains accented characters, Excel will not display them properly

without the BOM.

SQL: Here you can define your SQL query. For example select * from Plans.

You can also add to SQL constant header, for example

/* ExpHead

This is my constant header line 1.

This is my constant header line 2.

*/

select ...

Masks you can use in output file name:

· %expspath%  >  Represents standard CutLogic folder C:

\ProgramData\TMachines\CL1D\Exps\.

· COM  >  Output will be sent to (virtual) serial port. You can set serial port properties at

"Tools > Options > Serial port".

  

Masks you can use in output file name and SQL query:

· ActPlanID  >  ID of selected plan.

· ActPlanSouID  >  ID of selected stock in selected plan.

· ActPlanPartID

· ActMatID

· ActMatSouID

· ActMatPartID

· ActMatSettID

· ActStorID
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· ActStorSouID

· ActAssemID

· ActAssemPartID

· ActRepID

· ActPlanNum  >  Number (#) of selected plan.

· ActMatNum

· ActStorNum

· ActAssemNum

· ActRepNum

· ActPlanDes1  >  Description of selected plan.

· ActMatDes1

· ActStorDes1

· ActAssemDes1

· ActRepDes1

Masks you can use in SQL query:

· ActPlanIDs  >  refers to all multi-selected plans; for example select * from Plans where

ID in ActPlanIDs

· ActIDs  >  refers to all multi-selected records; for example select * from Mats where ID

in ActIDs

Masks you can use for field names in SQL queries:

·   _l  >  Transforms length value from database internal format to format set in

CutLogic, for example select 2 * (Len + Wid) Perim_l from Parts.

Press button Run to run selected export. (F3 or Ctrl+Enter)

Press button Insert to enter mask into SQL query.

Press button Copy to copy result of export into clipboard.

Custom exports support multi-selected data. For example if you multi-select 5 plans,

and then run export in Custom export form, all 5 plans will be exported.
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20 Database

CutLogic 1D uses for its data Firebird SQL database. It brings new features in terms of

security, reliability, networking and data management into the program. This chapter

describes how to maintain the data and the users.

To maintain the data select the menu item "Tools > Database".
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20.1 Backup

To backup or restore database, select the menu item "Tools > Database" and go on page

"Backup".

Automatic backup

Automatic backup enables you to define frequency of creation the backup files. Check one

or more options in Automatic backup area to match your backup strategy.

Note: Automatic backup works in the time loop. If you chose, for example, hourly

backup, system automatically creates new backup file every hour. After 24 hours new

backup file replaces the oldest backup file, so that the oldest available backup file

can not be older than 24 hours. Individual backups (Hourly, Daily, Weekly, etc.) work

independently, so for example if you set on Daily and Weekly backups, Daily backup

will keep backups for last 7 days (one backup per day); and Weekly backup will keep

backups for last 4 weeks (one backup per week).

Manual backup and restore

You can backup or restore your data anytime as you need.
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Send database

You can send your data via email for diagnostic purposes to our support department.
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20.2 Server

After the CutLogic 1D installation, program works in embedded database mode. You do

not have to install database separately - it is essential part of the program. However the

data saved in this embedded database is not available for other users and can not be

shared. Only way how to share the data is to install the Firebird database and switch the

CutLogic 1D to the network database mode.

Changing CutLogic 1D to the network database mode

To switch the program to the network database mode, select the menu item "Tools >

Database". Go on page "Server" and click the button [Change].

Fill in computer name or IP address where Firebird SQL server is installed and click the

[OK] button.
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Program automatically restarts and new Login dialog box appears.

Fill in user name and password and click the [OK] button to start the program.

Note: Firebird SQL server contains default user "SYSDBA" with default password

"masterkey". You can use this default user for login into CutLogic 1D or create new

users as described in chapter Users .

See also Network database setup .

140
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20.3 Users

CutLogic 1D has to work in network database mode to allow working with users. To add

new user, select the menu item "Tools > Database". Go on page "Users" and click the

button  to add new user.

Fill in the user name and the password, confirm the password and check the Access to

CutLogic 1D option and click the [OK] button.
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20.4 Statistics

The program enables you to show Firebird database statistics. This feature can be useful

especially for database administrators. To show the statistics, select the menu item "Tools

> Database". Go on page "Stats" and click the [Show stats] button.
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20.5 Network setup

First: Install Firebird and CutLogic 1D database file on the server

On the server computer:

1. Download Firebird SQL server version 2.5 64-bit at

https://www.firebirdsql.org/en/firebird-2-5/ and install it (use default settings,

don't change anything, just click Next buttons). Make sure that no firewall or other

SW blocks Firebird server on ports 3050 and 3051.

2. Copy or restore database file CL1D.fdb to chosen folder, e.g. C:

\CutLogic\CL1D.fdb.

To obtain CL1D.fdb, install CutLogic 1D on one of the station computers, then you

will find CL1D.fdb on station at:

C:\ProgramData\TMachines\CL1D\CL1D.fdb

3. In Firebird folder, open file aliases.conf and add to it line:

TMachines.CL1D = C:\CutLogic\CL1D.fdb

on Linux e.g.

TMachines.CL1D =  /opt/databases/CL1D.fdb

Make sure you have full write access right and file aliases.conf was really modified.

4. In Firebird folder, open file firebird.conf and add to it line:

RemoteAuxPort = 3051

Make sure you have full write access right and file firebird.conf was really

modified.

5. Write down computer name. It can be either computer name (e.g. JOECOMP), or IP

address (e.g. 192.0.2.25). Further we will refer to it as to ServerName.

6. Restart Firebird SQL server.

Second: Install CutLogic 1D on each station

On each station computer:

1. Install CutLogic 1D

2. Run CutLogic 1D, go to "Tools > Database > Server", and enter ServerName.

Third: Define users

1. Choose one station computer (any) and run CutLogic 1D, log in under username

"SYSDBA" and password "masterkey".

2. Go to "Tools > Database > Users" and define users - their user names and

passwords.
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Fourth: Security

It is recommended to change SYSDBA's password from default "masterkey" to your own

one. To do so, run CutLogic 1D, log in under username "SYSDBA" and password

"masterkey", and go to "Tools > Database > Users".
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